
AUTOMATION
CHAPTER 16

THE EXERCISES IN this chapter will explore the automation features of 

the Adobe Photoshop Actions panel. They will compare tasks that can 

be automated in Photoshop with a task that mandates human collabo-

ration with the application. You’ll duplicate and save copies of a single 

file, and then you’ll use Adobe Bridge to rename and view your work. 

The final result will be a set of files for the construction of a printed 

flipbook, which you’ll explore further in Chapter 17, Pagination and 

Printing.

As you’ll learn in this chapter, some aspects of image production can be 

automated. However, there are commands that require human decision-

making that cannot be easily expressed in code. Using the Photoshop 

Actions panel, you’ll create macros (called actions) to apply a set of 

commands to a single file or group of files. This programming alludes 

to the complexity of artificial intelligence: if only Photoshop were 

“smart” enough to edit images without our involvement, we could be on 

perpetual holiday.
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ARTIFICIAL ARTIFICIAL 
INTELLIGENCE
Although studies in artificial intelligence are constantly evolving, the field’s 
history includes paranoia and hoaxes. The automated chess-playing machine, 
also known as The Turk, was a notable artificial intelligence hoax created by 
Wolfgang von Kempelen in the 18th century. Benjamin Franklin and Napo-
leon Bonaparte each played chess against The Turk, losing the game to what 
appeared to be a robotic chess-playing device. In reality, the game was orches-

trated from within the body of 
the table on which it was set— 
by a human (FIGURE 16.1).

Fast-forward to November 2005, 
when Amazon.com launched 
the Mechanical Turk website 
(mturk.com), a virtual job board 
with the tagline, “Artificial arti-
ficial intelligence.” The Mturk 
website alludes to Von Kem-

pelen’s Turk hoax, whereby instead of humans moving chess pieces, humans 
are hired (usually for pennies) to complete tasks that are simple for humans 
but too complex for a computer to be programmed to fulfill. Anyone can sign 
up as a worker or employer to engage in this “crowdsourcing” phenomenon. 
Crowdsourcing is similar to outsourcing. While outsourcing implies hiring 
people from other geographical locations, the crowd is, similarly, a virtual 
mob of others. As an analogy to the Photoshop Actions panel, the types of 
jobs offered on Mturk.com belong in the category of commands that cannot be 
programmed as a Photoshop action. The difference between programmable 
actions or commands and those that require human interaction for proper 
completion is extremely complicated. Artists have created work responding to 
this complexity in the form of performance (see the work of the artist Stelarc), 
collage (see Constructivist collages such as El Lissitzky’s The Constructor), 
video (such as Tim Gruchy’s Scout), and web projects, as described below.

Websites facilitate Mturk.com’s crowdsourcing initiative in a variety of ways. 
Patricia Marx offers a witty narration of her use of the Task Rabbit website, 
and mentions Get Friday, Catch Friday, Ask Sunday, and Tasks Everyday in 
“Outsource Yourself” [1].

Aaron Koblin uses the workforce available on Mturk.com to create collabora-
tive multimedia projects (FIGURES 16.2 AND 16.3). For both The Sheep Market 

(2006) and Bicycle Built for Two Thousand (2009), Koblin asked workers to 
contribute one small human action (a drawing of a sheep facing left and a 
voice recording that matches a few notes, respectively), for which the contrib-
utors were paid in pennies through Amazon’s interface. These small actions 
(drawings and voice recordings) were then compiled into a larger project that 
required further editing by the artist.

READY, SET, ACTIONS!
While there are many ways to accomplish a single task in Photoshop, efficient 
practices include using key commands and, when appropriate, the Actions 
panel. There are three basic stages in developing Photoshop actions:

1. Record an action. Actions are created by recording a set of file manipula-
tions in an open Photoshop document. The Actions panel is an important 
tool for production artists, as the repeated application of a set of com-
mands (for instance, specific to file output) is a common task. Imagine 
preparing hundreds of high-resolution images for display on the web. This 
process would take hours if you approached the task one file at a time. 
Your workflow would be more efficient if instead you created an action that 
saved the series of repetitive commands and applied it to all images in the 
group. Once the action is recorded and saved, you can apply it to the entire 
group of images while you take a coffee break.

2. Stop recording the action. Many new students make the mistake of forget-
ting that the Actions panel is still recording, while they’ve moved on to 
other things. When you’re recording an action, focus on the task at hand. 
Once you’ve finished the steps you’d like to include in the recording, click 
the Stop icon to stop and save the action.

LINK See Tim Gruchy’s 
Scout at http://youtu.be/
WPM8u8i3xBE.

FIGURE 16.1 Karl Gottlieb 
von Windisch, copper 
engravings from the 
book Briefe über den 
Schachspieler des Herrn 
von Kempelen, nebst 
drey Kupferstichen die 
diese berühmte Maschine 
vorstellen, 1783.

REFERENCE [1] Patricia 
Marx, “Outsource Yourself,” 
The New Yorker,  
newyorker.com/report-
ing/2013/01/14/ 
130114fa_fact_marx.

FIGURE 16.2 Aaron Koblin, 
The Sheep Market, 2006.

FIGURE 16.3 Aaron Koblin 
and Daniel Massey, Bicycle 
Built for Two Thousand, 
2009.
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3. Play the action. Photoshop actions can be played on a single, open file in 
Photoshop or on a selection of files or even a folder of files from Bridge.

The following exercises demonstrate creating actions and the types of tasks 
that cannot be automated. The result is a short flipbook or faux stop-motion 
animation. Your flipbook will be only 10 pages in length for the purpose 
of keeping these exercises to a minimum time allotment. A longer book of 
approximately 60–80 pages would flip more easily.

EXERCISE 

1 CREATE AN ACTION

The Actions panel includes presets (none of which I’ve ever used) in the 
Default Actions folder. For the following exercises, you’ll create a new folder 
(or “set”) to store your flipbook actions.

1. Open chapter16-start.psd in Photoshop and display the Actions panel by 
choosing the Window menu > Actions.

2. Collapse the Default Actions set (FIGURE 16.5).

3. Click on the Create New Set icon in the bottom of the Actions panel, name 
it flipbook, and click the OK button (FIGURE 16.6). Notice the new set in the 
Actions panel.

In Chapter 17, Pagination 
and Printing, you’ll learn 
to assemble your book 
using Adobe InDesign.

WHAT YOU’LL NEED
Download the following source materials to com-
plete the exercises in this chapter:

✔✔ The chapter16-start folder from the Chapter 
16 downloads area on the companion website 
includes the chapter16-start file housing a 
Background layer and balloon-original layer 
group. 

Pay close attention to details as you create, save, 
and play your new action.

WHAT YOU’LL MAKE
In the exercises in this chapter, you’ll start with 
one Photoshop file and end up with a folder of 
TIFF images for printing as a flipbook. You’ll 
use the Actions panel to facilitate a sequence of 

programmable steps and modify each file by hand 
when you reach a point in the workflow that is not 
programmable (FIGURE 16.4). You’ll use the folder 
of images created in this chapter to begin the 
exercises in Chapter 17.

FIGURE 16.4 In these exercises, you’ll create an action to 
duplicate files and then add unique modifications to each 
individual file.

IMAGE CREDIT I created the 
background image to act 
as the “stage” on which the 
balloon flies. The balloon 
image is Alfred T. Palmer’s 
Parris Island, S.C., barrage 
balloon, 1942, LOC Call 
number: LC-USW36-226. 
You can download it in its 
original format from the 
Library of Congress Flickr 
photostream at www.flickr.
com/photos/library_of_con-
gress/2178246585/. 

WORKSPACE > ESSENTIALS 
Open Photoshop and set 
the workspace to Essentials 
using the pull-down list in 
the Application bar or by 
choosing the Window menu 
> Workspace > Essentials.

4. Click on the Create New Action icon in the bottom of the Actions panel, 
name it duplicate, assign it the function key F1 and the color red, and click 
the Record button (FIGURE 16.7).

5. Notice that you’re now recording! There is a red Recording icon in the bot-
tom of the Actions panel that you probably didn’t notice was gray before 
now (FIGURE 16.8).

SCREENCAST 16-1 REVIEW OF THE PEN TOOL, 
LAYER MASKS, AND ADJUSTMENT LAYERS

The file you’ll use to develop your flipbook action has been somewhat prepared for 
you to save time and reduce redundancy in the text. View this chapter’s screencast 
to see how I used the Pen tool and a layer mask to isolate the balloon and make the 
color modifications within the ballon-original layer group. This material is introduced 
in Section 3, Digital Manipulation and Fair Use.

All screencasts are available on the companion website, www.digitalart-design.com, or on the 
YouTube playlist, www.youtube.com/playlist?list=PLAy6P5IoEjy2v3kZKCt8spqJ50nLb2XQI.

FIGURE 16.5 Expand and collapse sets in 
the Action panel.

FIGURE 16.6 Create a new action set.

FIGURE 16.7 When you 
create a new action, 
you’ll exit the dialog box 
by clicking the Record 
button. Don’t forget to stop 
recording when you’re 
finished!FIGURE 16.8 The 

Recording icon is red 
when you’re recording 
your action.

KEY COMMAND If the F1 
key is unavailable (per-
haps it’s being used for 
something else on your 
system), you can choose 
any available function 
key. However, in Exercise 
2, Step 4, you’ll need to 
substitute pressing the 
key you assigned in lieu 
of F1.
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1. Notice that you now have the original start file open, as well as a copy. 
Close the original start file to preserve it. (You may want to start anew.)

2. With the chapter16-start copy.psd open and active, click once to activate 
the Duplicate action (it’s probably already active since it’s the last action 
you worked on); then click the Play icon in the bottom of the Actions panel 
(FIGURE 16.12).

3. Within a second or two, a new tab is created for the duplicate document, 
named chapter16-start copy 2.psd. 

4. Now play that action again using a different method: instead of clicking 
the Play icon, press the F1 key on your keypad. Remember: Mouse clicks 
are less effective than keystrokes. Now you have a third tab for  
chapter16-start copy 3.psd.

6. In the following mini-steps, you’ll create or record or program (use which-
ever verb will help you remember to stop recording when you’re done) your 
action:

a. Choose the Image menu > Duplicate. Don’t change the default name. (It 
will be the same name as your current file with an added dash and the 
word “copy.”) Click the OK button.

b. Choose the File menu > Save As and do not rename the file. Instead, 
click the Save As a Copy button (FIGURE 16.9). The name of the file will 
be chapter16-start copy.psd. Click the Save button.

c. Click the Stop icon at the bottom of the Actions panel to stop recording 
your first action (FIGURE 16.10).

PLAY AN ACTION

You can play an action on a single open file or on a folder of files in what’s 
called a “batch.” For this exercise, you’ll simply apply the Duplicate action 
repeatedly, using two methods on an open file. In Chapter 17, you’ll learn to 
apply an action to a batch of files.

WATCH OUT! If you’re 
new to creating Actions, 
you’ll inevitably forget 
to stop recording when 
you first try doing this on 
your own. Be mindful of 
this common mistake.

FIGURE 16.9 If you use the 
Save command when you 
record an action, make sure 
that you don’t change the 
name of the file.

FIGURE 16.10 Click the Stop 
icon to finish making an 
action.

SAVING WHILE CREATING AN ACTION

Be careful about applying the Save or Save As commands when you’re recording a 
new action. Here are some tips to keep in mind:

• If you record the Save command (File menu > Save), then you’ll overwrite the 
original file. 

• If you don’t change the file name, it’s safe to record the Save As command (File 
menu > Save As). 

• It’s common to record the Save As command and change the location where the 
new files will be stored. (That is, choose File menu > Save As—don’t change the 
file name, but save the file in a new folder.) 

• If you add the Save As command to your action, you can always check the path in 
the recorded action once you’re finished to see where the file is saved and whether 
you accidentally assigned a name to it (FIGURE 16.11). If you notice that the Save 
or Save As command includes a file name, delete and re-record this part of the 
action. Click the Trash icon in the bottom of the Actions panel to delete an action 
or a part of an action and click the Record icon to record within an action. (Don’t 
forget to click the Stop icon when you’re done!)

FIGURE 16.11 Expand the Action panel to see the file path if you’ve included the Save 
command in your action.

EXERCISE 

2

FIGURE 16.12 Play an action 
using the Play icon in the 
Actions panel.
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5. Play the action one more time using a different method before deciding 
which way you prefer to work. Click the top-right Actions pull-down menu 
and choose Button Mode to display each saved action as a clickable button 
(FIGURE 16.13). Yours will likely be at the bottom of the list of buttons—
remember that you set it in red, which should make it easy to spot. Click 
the Duplicate button one time (FIGURE 16.14). Now you have a fourth tab for 
chapter16-start copy 4.psd.

6. Choose which work habit you find most effective and use the Duplicate 
action to create six more copies of the file. You’ll have 10 copies of the file 
in total. (The last file will be named chapter16-start copy 10.psd.)

KEY COMMAND If the 
F1 key was unavailable 
when you created your 
action in Exercise 1, Step 
4, you may have assigned 
a different function key to 
this action. Press that key 
instead of F1 to play your 
action. 

FIGURE 16.13 Enter Button 
Mode from the pull-down 
menu in the Actions panel.

FIGURE 16.14 Play an action 
by clicking its button.

SAVING AND LOADING ACTIONS

The Action panel will store sets of actions that you create on your computer. But, if 
you’re working in a shared computer lab or need to deinstall or reinstall Photoshop, 
you won’t see your actions. It’s wise to save your actions for later use, regardless of 

where you’re working. Saving and 
loading actions to the Actions panel 
is simple. Just click on the top-right 
pull-down menu in the Actions panel 
and choose Save Actions to save a set 
of actions as an .atn file (FIGURE 16.15). 
Load Actions is also visible in this 
menu—choose it to open (or “load”) a 
saved action file (.atn) from your hard 
drive.

FIGURE 16.15 Save a set of actions from the 
pull-down menu in the top-right corner of 
the Actions panel.

EXERCISE 

3 BATCH RENAME REVISITED

Do you remember renaming a set of files using Bridge from the exercises 
in Chapter 4, Creating and Organizing Digital Photographs? If not, review 
Chapter 4, Exercise 7, or watch Screencast 4-1 Renaming Files in Bridge to 
complete the next steps.

1. Close all of the open files in Photoshop—they’re all saved to your chapter16 
folder. Do this quickly by pressing Command (⌘)-W to close the window 
and ⌘-D to activate the Don’t Save choice.

2. Open Bridge and navigate to the chapter16 folder where you saved these 
new images. 

3. Select the 10 copies of the chapter16-start.psd file.

4. Choose the Tools menu > Batch Rename.

5. Rename the files in the same folder and set the new file name to simply 
show a two-digit sequence number (FIGURE 16.16). You may need to click 
the Minus icon to the right of the list of naming conventions to simplify the 
file name. Click the Rename button.

6. Open all 10 files (now named 01.psd, 02.psd, and so on, through 10.psd) 
in Photoshop. If your setup is similar to mine, you’ll be viewing all 10 
selected files in Bridge upon renaming them. Simply double-clicking one 

FIGURE 16.16 Use the 
Batch Rename dialog box 
to create a new file name 
with two-digit sequence 
numbers.

If you’re working in a 
computer lab, your lab 
technician may not have 
set the preferences in 
Bridge such that the files 
open in Photoshop. You 
can use whatever tech-
nique is effective to open 
all 10 files in Photoshop.

384  FOUNDATIONS OF DIGITAL ART AND DESIGN WITH ADOBE CREATIVE CLOUD CHApTER 16:  AUTOmATION  385



of the selected files will prompt Bridge to open all 10 files in Photoshop. 
(Click OK through the warning message.) 

EXERCISE 

4 FLOAT FILES IN WINDOWS

You’ll begin this set of steps by setting up your workspace to see each docu-
ment as if it were the frame of a movie (or in your case, a flipbook).

1. With all 10 files open in tabs, choose the Window menu > Arrange > Float 
All in Windows.

2. Choose the Window menu > Tile.

3. Activate any of the windows and reduce the zoom so you can see the 
entire composition in the space. (I ended up at 25%, but you may reduce 
to a lower or higher percentage depending on your screen resolution.) 

4. Choose the Window menu > Match Zoom. Now all 10 documents are 
open, and you can clearly see each composition (FIGURE 16.17).

5. Look at the layout of your documents. Where is 01.psd located and where 
is 10.psd on the screen? Mine are in order if I view the documents as 
columns to be read from left to right. If yours are out of order, choose 

the File menu > Close All Documents and then try this exercise again 
from Step 1. Alternatively, click and drag to rearrange the document loca-
tions so the order makes sense to you.

NONPROGRAMMABLE MODIFICATIONS

The final steps are to modify where the balloon appears in each composition. 
This is something that you can’t program with an action, as it requires your 
eye and brain to perceive and sculpt the space.

1. Click on the document 01.psd to activate it. Make sure that the balloon-

original layer group is selected. Use the Move tool combined with Edit 
menu > Free Transform to move, scale, and rotate the balloon in whatever 
way you like. I started my flipbook with the balloon coming in from the left 
side of the document, high in the sky. You might also apply a layer mask to 
blend the balloon into the clouds.

2. Press ⌘-S to save 01.psd when you’re finished modifying the composition.

3. Activate 02.psd and manipulate the balloon on the composition to suggest 
movement. Save the file when you’re done.

4. Repeat these manipulations in each of the 10 documents. You might add 
masks; reduce the opacity of the balloon; change the balloon’s rotation, 
placement, or size; or add imagery or color to the documents (FIGURE 16.18).

5. Make sure that all of your files are saved, then choose File menu > Close 
All.

In theory, you could have 
simply selected Window 
menu > Tile without 
floating the images, 
but I’ve found that for 
some reason my files 
appeared out of order 
when I excluded the float 
step. Watch out for this 
in Step 5.

FIGURE 16.17 Use Match 
Zoom to see all the open 
documents at the same 
zoom-level when they’re 
tiled in separate windows.

FIGURE 16.18 Modify each 
document separately to 
craft your story.

EXERCISE 

5

386  FOUNDATIONS OF DIGITAL ART AND DESIGN WITH ADOBE CREATIVE CLOUD CHApTER 16:  AUTOmATION  387



WATCH THE SEQUENCE PLAY IN BRIDGE

While the final result will be a printed booklet, you can preview how your 
balloon “actor” moves across the “stage” (the background layer) using the 
Filmstrip workspace in Bridge.

1. If Bridge is still open, press ⌘-Tab (Mac) to toggle to Bridge. Otherwise, 
open Adobe Bridge.

2. Navigate to the chapter16 folder. Activate the Filmstrip workspace. Click 
the Filmstrip button in the Application Bar or choose the Window menu > 
Workspace > Filmstrip.

3. Select the files that will appear as pages 01.psd through 10.psd by click-
ing once on the 01.psd file, holding the Shift key, and clicking once on the 
10.psd file. With all 10 files selected, press ⌘-5 to apply a five-star rating 
label to the files (FIGURE 16.19).

4. Deselect all files by pressing ⌘-⇧-A or by choosing the Edit menu > 
Deselect All.

5. Display only the files with a five-star rating by clicking on the five star 
icons in the Filter panel (FIGURE 16.20). 

6. Click once on the first file, 01.psd. Press the Right Arrow key and hold it as 
Bridge displays each subsequent file in the Preview area.

LAB CHALLENGE

Develop an action to create a story that you plan to illustrate in a flipbook. 
Your story should be one that’s not physically possible in the analog world. 
Use digital manipulation tools to create a visual narrative that defies the rules 
of gravity, permanence, or time.

EXERCISE 

6

FIGURE 16.19 Selected files in Bridge’s 
Filmstrip workspace have a five-star rating.

FIGURE 16.20 Filter the display of images in 
Bridge to those with five-star ratings.

FILTER PANEL The Filter 
panel lets you sort your 
view of files in Bridge. You 
can add the two remain-
ing files to your Filtered 
View by clicking No Rat-
ing. Notice that two files 
have been assigned No 
Rating, and 10 files have 
a rating, or label, of five 
stars.
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