
FIGURE S5.1 Tim Belonax, A Machine for Typographic Generation. 
Client: The THING Quarterly, 2012.



THIS LAST SECTION again aims to merge art, design, and technol-
ogy in a way that fuses separate parts of the craft, history/theory, 
and reflection triad. As readers, learners, and educators, we have 
all experienced how this process can be challenging, because it’s 
easy for the technical part of the learning curve to overshadow 
the places from which an artist or designer is inspired (historical 
visual works and theories or principles). In Section 4, Typogra-
phy, for instance, learning the nuances of type might have seemed 
more important than memorizing the shortcuts in the applications 
used to set type. Different schools deal with this dilemma in differ-
ent ways: Some separate the “skills” classes into smaller sections 
taught by seemingly “less important” staff (diminishing the value 
of craft or those who specialize in being able to articulate this 
important aspect of the digital realm, in my opinion); others offer a 
combined lecture/lab model in which the instructor meanders from 
one end of the spectrum (history, let’s say) to the other (an Adobe 
Photoshop tutorial), often without connecting the dots between the 
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two. As mentioned in the book’s introduction, this is the pedagogical gap this 
text aims to fill.

For this section, consider what it means to work effectively—specifically when 
the tools at your fingertips are primarily digital. Arrange your workspace ergo-
nomically. Learn as many keyboard shortcuts as you can, because pressing 
keys is less stressful on your wrist than moving a mouse or using a trackpad, 
and it results in making fewer errors. Consider what it means to be effective 
(or strategic) in an era of cut, copy, and paste.

ERGONOMICS

This may seem obvious, but all too often I hear of students and friends who set up 
their computing workstations without thinking about their health and safety. Here 
are a few guidelines to keep in mind while designing an ergonomically correct work 
environment:

•	 Height The height of the monitor should be at eye level, and the keyboard should 
be aligned with your elbows. You can adjust your desktop or seat and use a 
keyboard pad to reap the benefits of this essential positioning guideline. Proper 
positioning of the monitor will help to alleviate neck and shoulder cramping. 
Proper positioning of the keyboard (possibly with a pad) will align your wrists to 
avoid carpal tunnel or other repetitive stress injuries.

•	 Light You should have enough light to see the monitor without squinting your 
eyes or sensing glare from the screen. In some cases, this might require a set of 
multiple lights positioned around your workstation.

•	 Seat The seat of your chair should be comfortable. Your knees should be at a 
90-degree angle to the floor. You may find more comfort by adding a small pillow 
or rolled towel to support your lower back.

•	 Feet Your feet should be flat on the floor or resting flat on an elevated surface if 
the floor is unreachable.

•	 Breaks Take frequent breaks. Set a timer if you need to remind yourself to move 
every hour. Stretch your back, shoulders, and legs, and give your eyes a break 
from short-distance viewing.

AUTOMATION
Automation can result from the invention of new technological processes. 
From Henry Ford’s mass production of the Model T in 1908 to ATMs (auto-
matic teller machines) popularized in the late 20th century, automatic 
processes imply a combination of a human nudge and a computerized system 
for completing a set of directions. In literary circles, “automation” is found in 
automatic writing. Arthur Conan Doyle and Jane Roberts believed that they 
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channeled spirits and that they 
themselves became the automaton. 
Automatic writing is also referred to 
as stream of consciousness writing, 
without a spiritual connotation. This 
was a method practiced by Virginia 
Woolf and James Joyce, the latter 
for “finding” his characters without 
the noise of the conceptual mind. 
The French group Oulipo also used 
rule-based writing techniques to 
“automatically” create or inspire new 
textual works.

Automation can also refer to 
mechanical processes that hint 
at artificial intelligence. An art or 
design practice that relies on system-
atic automation certainly has relatives from the era of conceptual art, in which 
the directive created by the artist was executed, knowingly or unknowingly, by 
participants. Sol LeWitt’s wall drawings were drawn by the gallery staff based 
on a set of directions from the artist. Stanley Brouwn’s This Way Brouwn series 
of hand-drawn maps by passersby exemplify this type of conceptually driven 
artifact, produced “automatically” (or, at least, according to a set of rules) by 
nearly anyone but the artist who originated the idea.

Automation also suggests generative art, which is created by some automatic 
or rule-driven processes. Typically, there are some basic themes to the char-
acter or nature of the work of art, and as it develops, it mutates based on the 
system inherent to the process. Digital artists may mistakenly think of genera-
tive art as “software art,” although this is not accurate. Generative systems 
are biological and can be produced in all areas of expression from music to 
literature to digital art. In response to Cornelia Sollfrank’s net.art generator 
(FIGURE S5.2), Sarah Cook articulates how technology has transformed from a 
system for delivering media to a system for creating it:

In the cultural sphere, technology is often misunderstood as merely a delivery 
medium for fixed content (one needs to think only of the progression in infor-
mation transmission from the telegraph, to the telephone, to the television). 
“Generative art” turns this idea on its head—wherein not only is the content 
not fixed in advance, but the technology is the medium for that variable and 
manipulated content [1].

While you won’t create (or program) “software art” in these chapters, you’ll 
learn about automatic processes available to you in the Photoshop Actions 

REFERENCE [1] Sarah Cook, 
“What would artificial intel-
ligence find aesthetically 
pleasing? The burning 
question of generative art 
and its audience,” 2003. 
net.art-generator.com/
publications_cook_en.html.

FIGURE S5.2 net.art generator, Cornelia Sollfrank (since 1997),  
net.art-generator.com. Also see: www.youtube.com/watch?v=43y2k5j7oIU.
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panel. You can use this panel to direct Photoshop to perform a series of steps 
on one or several images. Most of the time, the goal is to re-create the same 
effect with a Photoshop action, so this particular automatic process lacks 
the transformative quality common to generative art. In Chapter 13, however, 
you’ll learn to give directions to the computer (via Photoshop) and reap the 
benefits of an incredibly effective working process for common digital imaging 
commands.

PRINTING
Printing can be as easy as clicking the Print button (for instance, if you’re 
printing a Word document or PDF file) and as complicated as you can imagine 
if you’re trying to match colors to a proof or print on the front and back of the 
page to create a book or pamphlet. You learned about RGB and CMYK color 
spaces in Chapter 6, Color Models. In Chapter 14, Pagination and Printing, 
you’ll revisit the Actions panel from Adobe Bridge before learning to manually 
paginate the printing of a booklet in Adobe InDesign.

GENERATIVE ART RESOURCES

•	 “Generative Art—Computers, Data, and Humanity” (Off Book, PBS), youtu.be/
x0OK1GiI83s

•	 “Getting Started with Generative Art” (by Jeya, Media Militia), mediamilitia.com/
getting-started-with-generative-art

•	 Inspirational artists include Joshua Davis, Ben Fry, Golan Levin, John Maeda,  
Mark Napier, Casey Reas, and Scott Snibbe

Printing is a craft for which there are many techniques. What you make with 
your prints can span a wide conceptual and aesthetic range. Letterforms or 
basic lines and shapes are used in spreadsheets and text documents, post-
ers and brochures, activist publications, artists’ books developed for exhibi-
tion purposes, and more. Tim Belonax’s The Thing contribution for SASE #3, 
A Machine for Typographic Generation, fits both themes in this section: 
automation and printing (see FIGURE S5.1 at the beginning of this section). His 
machine encourages viewers/users to develop letterforms from a stencil sys-
tem he created. Belonax’s machine is one that results in hand-drawn letters, 
a quality that contemporary artists’ books or graphically designed ephemera 
miss, due to the popularity and ease of production of digital output.
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REVISION
Revision is as much a part of the creative process as brainstorming and com-
manding the tools of a craft to execute your vision. It simply cannot be denied, 
and when you’re developing your own projects, you should always budget 
more time for revision than you think you may need. In any expressive media, 
the revision process begins as soon as you make a decision. Some people have 
a set regime, while others revise based on reactions to their first (or tenth) 
attempt. Revision is personal—everyone has his or her own way of editing.

The Coda contains a series of contributions and interviews with artists and 
designers about their revision processes. These stories demonstrate the effec-
tiveness of revision and many ways to approach it.
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THE EXERCISES IN this chapter will explore the automation features 

of the Adobe Photoshop Actions panel. They will compare tasks that 

can be automated in Photoshop with a task that mandates human col-

laboration with the application. You’ll duplicate and save copies of a 

single file, and then you’ll use Adobe Bridge to rename and view your 

work. The final result will be a set of files prepared for publication 

in a printed flipbook. You’ll assemble the book by creating a docu-

ment featuring multi-page layout using Adobe InDesign in Chapter 14, 

 Pagination and Printing.

As you’ll learn in this chapter, some aspects of image production can 

be automated. However, other commands require human decision-

making that cannot be easily expressed in code. Using the Photoshop 

Actions panel, you’ll create macros (called actions) to apply a set of 

commands to a single file or group of files. This programming alludes 

to the complexity of artificial intelligence: if only Photoshop were 

“smart” enough to edit images without our involvement, we could be 

on perpetual holiday.

AUTOMATION
CHAPTER 13
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ARTIFICIAL ARTIFICIAL 
INTELLIGENCE
Although studies in artificial intelligence are constantly evolving, the field’s 
history includes paranoia and hoaxes. The automated chess-playing machine, 
also known as The Turk, was a notable artificial intelligence hoax created by 
Wolfgang von Kempelen in the 18th century. Benjamin Franklin and Napo-
leon Bonaparte each played chess against The Turk, losing the game to what 
appeared to be a robotic chess-playing device. In reality, the game was orches-
trated from within the body of the table on which it was set—by a human 
(FIGURE 13.1).

Fast-forward to November 2005, when Amazon.com launched the Mechani-
cal Turk website (Mturk.com), a virtual job board with the tagline, “Artificial 
artificial intelligence.” The Mturk website alludes to von Kempelen’s Turk 
hoax, whereby instead of humans moving chess pieces, humans are hired 
(usually for pennies) to complete tasks that are simple for humans but too 
complex for a computer to be programmed to fulfill. Anyone can sign up as 
a worker or employer to engage in this crowdsourcing phenomenon. Crowd-
sourcing is similar to outsourcing. While outsourcing implies hiring people 
from far away geographical locations, the crowd is, similarly, a virtual mob of 
“others,” distanced by the anonymity of the virtual platform. As an analogy to 
the Photoshop Actions panel, the types of jobs offered on Mturk.com belong 
in the category of commands that cannot be programmed as a Photoshop 
action. The difference between programmable actions or commands and those 
that require human interaction for proper completion is complicated. Artists 
have created work responding to this complexity in the form of performance 
(see the work of the artist Stelarc), collage (see Constructivist collages such as 
El Lissitzky’s The Constructor), video (such as Tim Gruchy’s Scout), and web 
projects, as described below.

LINK See Tim Gruchy’s 
Scout at youtu.be/
WPM8u8i3xBE.

FIGURE 13.1 Karl  Gottlieb 
von Windisch, copper 
engravings from the 
book Briefe über den 
Schachspieler des Herrn 
von Kempelen, nebst 
drey Kupferstichen die 
diese berühmte Maschine 
 vorstellen, 1783. The  
History Collection/Alamy  
Stock Photo.
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Companies facilitate Mturk.com’s crowdsourcing initiative in a variety of ways. 
Patricia Marx offers a witty narration of her use of the Task Rabbit website, 
and mentions Get Friday, Catch Friday, Ask Sunday, and Tasks Everyday in 
“Outsource Yourself” [1].

Aaron Koblin uses the workforce available on Mturk.com to create collabora-
tive multimedia projects (FIGURES 13.2 AND 13.3). For both The Sheep Market 
(2006) and Bicycle Built for Two Thousand (2009), Koblin asked workers to 
contribute one small human action (a drawing of a sheep facing left and a 
voice recording that matches a few notes, respectively), for which the contrib-
utors were paid in pennies through Amazon’s interface. Koblin then compiled 
these small actions (drawings and voice recordings) into a larger project that 
required further editing by the artist.

FIGURE 13.2 Aaron Koblin, 
The Sheep Market, 2006.

FIGURE 13.3 Aaron Koblin 
and Daniel Massey, Bicycle 
Built for Two Thousand, 
2009.

REFERENCE [1] Patricia 
Marx, “Outsource Yourself,” 
The New Yorker, newyorker.
com/magazine/2013/01/14/
outsource-yourself
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READY, SET, ACTIONS!
While there are many ways to accomplish a single task in Photoshop, efficient 
practices include using key commands and, when appropriate, the Actions 
panel. There are three basic stages in developing Photoshop actions:

1. Record an action. Actions are created by recording a set of image file 
manipulations in an open Photoshop document. The Actions panel is an 
important tool for production artists, as the repeated application of a set 
of commands (for instance, those specific to file output) is a common task. 
Imagine preparing hundreds of high-resolution images for display on the 
web. This process would take hours if you approached the task one file at 
a time. Your workflow would be more efficient if instead you created an 
action that saved the series of repetitive commands and then automati-
cally applied it to each image in the group. After the action is recorded 
and saved, you can apply it to the entire group of images while you take a 
coffee break.

2. Stop recording the action. It may seem outlandish to mention this, but 
many new students make the mistake of forgetting to click the Stop icon. 
If you do, the Actions panel will continue to record everything you do— 
adding steps or commands you didn’t intend to be part of your action. 
When you’re recording an action, focus on the task at hand. Once you’ve 
finished the steps you’d like to include in the recording, click the Stop icon 
to stop and save the action.

3. Play the action. Photoshop actions can be played on a single, open file in 
Photoshop or on a selection of files or even a folder of files from Bridge.

The following exercises demonstrate creating actions for commands that can 
be automated, as well as the types of tasks that cannot be automated. The 
result is a short flipbook or faux stop-motion animation. Your flipbook will be 
only 10 pages long for the purpose of keeping these exercises to a minimum 
time allotment. A longer book of approximately 60 to 80 pages would flip 
more easily.

In Chapter 14, Pagination 
and Printing, you’ll learn 
to assemble your book 
using Adobe InDesign 
after you have created a 
batch action from Bridge 
to Photoshop.
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EXERCISE 

1 CREATE AN ACTION

The Actions panel includes presets (none of which I’ve ever used) in the 
Default Actions set. For the following exercises, you’ll create a new set to store 
actions created for this project. Then you will create an action named dupli-

cate that copies and saves a file.

1. Open chapter13-start.psd in Photoshop, and display the Actions panel by 
clicking the Actions icon (I think of the sideways triangle as a reference to 
the Play button) towards the right of the application window or by choos-
ing Window > Actions.

2. Collapse the Default Actions set (FIGURE 13.5).

3. Click the Create New Set icon at the bottom of the Actions panel, name it 
flipbook, and click the OK button (FIGURE 13.6). Notice the new set in the 
Actions panel.

WORKSPACE > 
 PHOTOGRAPHY Open 
 Photoshop and set the 
workspace to Photogra-
phy using the Workspace 
Switcher in the Options bar 
or by choosing Window > 
Workspace > Photography.

WHAT YOU’LL NEED
Download the following source materials to com-
plete the exercises in this chapter:

✔✔ The chapter13-workfiles.zip file from the 
Chapter 13 downloads area on the companion 
website includes the chapter13-start.psd file 
with a Background layer and balloon-original 
layer group.

Pay close attention to details as you create, save, 
and play your new action.

WHAT YOU’LL MAKE
In the exercises in this chapter, you’ll start with 
one Photoshop file and end up with a folder of 
TIFF images to print as a flipbook. You’ll use the 
Actions panel to facilitate a sequence of program-
mable steps and modify each file by hand when 

you reach a point in the workflow that is not 
programmable (FIGURE 13.4). You’ll use the folder 
of images created in this chapter to begin the exer-
cises in Chapter 14.

FIGURE 13.4 In these exercises, you’ll create an action to 
duplicate files and then add unique modifications to each 
individual file.

IMAGE CREDITS I created the background image to act as the “stage” on which the balloon flies. The balloon image is Alfred T. 
Palmer’s Parris Island, S.C., barrage balloon, 1942, LOC Call number: LC-USW36-226. You can download it in its original format 
from the Library of Congress Flickr photostream at www.flickr.com/photos/library_of_congress/2178246585.
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FIGURE 13.5 Collapse or expand sets in the Action panel. You can see 
that I have saved a couple of action sets in my panel.

FIGURE 13.6 Create a new action set.

SCREENCAST 13-1 REVIEW OF THE PEN TOOL, 
LAYER MASKS, AND ADJUSTMENT LAYERS

The file you’ll use to develop your flipbook action has been somewhat prepared for 
you to save time and reduce redundancy in the text. View this chapter’s screencast 
to see how I used the Pen tool and a layer mask to isolate the balloon and make 
the color modifications within the balloon-original layer group. This material is intro-
duced in Section 3, Digital Manipulation and Free Fair Use.

All screencasts are available on the companion website, www.digitalart-design.com, or on 
the Vimeo playlist, http://bit.ly/foundations-demos.

4. Notice the flipbook set is selected—as you create a new action, it will be 
added to this set. Click the Create New Action icon at the bottom of the 
Actions panel, name it duplicate, assign it the function key F9 and the 
color Red, and click the Record button (FIGURE 13.7).

Notice that you’re now recording! There is a red Recording icon in the bot-
tom of the Actions panel that you probably didn’t notice was gray before 
now (FIGURE 13.8).

5. In the following mini-steps, you’ll create or record or program (use which-
ever verb will help you remember to stop recording when you’re done) 
your action:

a. Choose Image > Duplicate. Don’t change the default name. (It will be 
the same name as your current file with an added dash and the word 
“copy.”) Click the OK button.

KEYBOARD SHORTCUT If 
the F9 key is unavailable 
(perhaps it’s being used 
for something else on 
your system), you can 
choose any available 
function key. However, in 
Exercise 2, Step 4, you’ll 
need to substitute press-
ing the key you assigned 
in lieu of F9.
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FIGURE 13.7 When you create a new action, you’ll exit the dialog box by clicking the Record 
 button. Don’t forget to stop recording when you’re finished!

FIGURE 13.8 The Recording 
icon is red when you’re 
recording your action.

FIGURE 13.10 Click the Stop 
icon to finish making an 
action.

FIGURE 13.9 If you use the Save As command when you record an action, make sure that you 
don’t change the name of the file.

b. Choose File > Save As and do not rename the file. Instead, select Save: 
As A Copy (FIGURE 13.9). The name of the file will be  chapter13-start 

copy.psd. Navigate to the chapter13-start folder if your file is not 
already set to save in this location, and click the Save button.

c. Click the Stop icon at the bottom of the Actions panel to stop recording 
your first action (FIGURE 13.10).

WATCH	OUT! If you’re 
new to creating actions, 
you’ll inevitably forget 
to stop recording when 
you first try doing this 
on your own. Be mindful 
of this common mistake. 
If the Record icon is red, 
you’re still recording!
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EXERCISE 

2 PLAY AN ACTION

You can play an action on a single open file or on a folder of files in what’s 
called a batch. For this exercise, you’ll simply apply the duplicate action 
repeatedly, using three methods on an open file. In Chapter 14, you’ll learn to 
apply an action to a batch of files.

1. Notice that you now have the original start file open, as well as a 
copy. Close the original start file to preserve it. (You may want to start 
anew later.)

2. With the chapter13-start copy.psd open and active, click the name of the 
duplicate action once to select it, then click the Play icon in the bottom of 
the Actions panel (FIGURE 13.12).

SAVING WHILE CREATING AN ACTION

Be careful about applying the Save or Save As commands when you’re recording a new action. Here are some tips 
to keep in mind:

•	 If you record the Save command (File > Save), then you’ll overwrite the original file.

•	 If you don’t change the file name, it’s safe to record the Save As command (File > Save As) and change the loca-
tion for the new, saved file.

•	 If you add the Save As command to your action, you can always check the path in the recorded action once 
you’re finished to see where the file is saved and whether you accidentally assigned a name to it (FIGURE 13.11). If 
you notice that the Save or Save As command includes a file name, delete and rerecord this part of the action. 
Click the Trash icon in the bottom of the Actions panel to delete an action or a part of an action, and click the 
Record icon to record within an action. (Don’t forget to click the Stop icon when you’re done!)

FIGURE 13.11 Expand the Save command in the duplicate action to see the file path you saved in your action. My file path 
is long. Among the many locations it includes are the name of the folder where I have been saving files for this book and 
the chapter13-start folder.
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Within a second or two, a new tab is created for the duplicate document, 
named chapter13-start copy 2.psd.

3. Now play that action again using a different method: Instead of clicking 
the Play icon, press the F9 key on your keypad. Remember, mouse clicks 
are less effective than keystrokes. Now you have a third tab for chapter13-

start copy 3.psd.

4. Play the action one more time using a different method before deciding 
which way you prefer to work. Click the top-right Actions panel menu, and 
choose Button Mode to display each saved action as a clickable button 
( FIGURE 13.13). Mine is at the bottom of the left column of buttons, yours 
will likely also be at the bottom of the list of buttons—remember that you 
set it in red, which should make it easy to spot.

5. Click the duplicate button one time (FIGURE 13.14). Now you have a fourth 
tab for chapter13-start copy 4.psd.

KEYBOARD SHORTCUT  
If the F9 key was unavail-
able when you created 
your action in Exercise 1, 
Step 4, you may have 
assigned a different func-
tion key to this action. 
Press that key instead of 
F9 to play your action.

FIGURE 13.12 Play an action using the 
Play icon in the Actions panel.

FIGURE 13.13 Enter Button mode using the Actions panel menu.

FIGURE 13.14 Play the duplicate action by clicking its button in Button mode. Now you should have created 
four copies of the original file.
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6. Choose the work habit you find most effective, and use the duplicate action 
to create six more copies of the file. You’ll have 10 copies of the file in total. 
(The last file will be named chapter13-start copy 10.psd.)

SAVING AND LOADING ACTIONS

The Action panel will store sets of actions that you create on your computer. But, if 
you’re working in a shared computer lab or need to deinstall or reinstall Photoshop, 
you won’t see your actions. It’s wise to save your actions for later use, regardless of 
where you’re working. Saving and loading actions to the Actions panel is simple. Start 
by viewing Actions in the default mode (not Button mode). Click on any action set, 
then open the Actions panel menu and choose Save Actions to save a set of actions as 
an .atn file (FIGURE 13.15). Load Actions is also visible in this menu—choose it to open 
(or “load”) a saved action file (.atn) from your hard drive.

FIGURE 13.15 Save a set 
of actions using the 
Actions panel menu.

EXERCISE 

3 BATCH RENAME REVISITED

Do you remember renaming a set of files using Bridge from the exercises 
in Chapter 4, Creating and Organizing Digital Photographs? If not, review 
 Chapter 4, Exercise 7, or watch Screencast 4-1 Renaming and Ranking Files  
in Bridge before you complete the next steps.

1. Close all of the open files in Photoshop—they’re all saved to your 
 chapter13-start folder. Do this quickly by pressing Command-W/Ctrl-W to 
close the window and Command-D/Ctrl-D to activate the Don’t Save choice.
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2. Drag the chapter13-start folder to the Bridge icon to open Bridge and view 
these files. Or, open Bridge and navigate to where you saved these new 
images.

3. Set Bridge to use the Essentials workspace by clicking the button in the 
Application Frame or choosing Window > Workspace > Essentials.

4. Select one of the chapter13-start.psd files, then hold the Shift key to add to 
the selection until all 10 of the duplicate files that you created are selected.

5. Choose Tools > Batch Rename.

6. Rename the files to a simple two-digit sequence number, and save them 
in a results folder. To do this, click the Move To Other Folder button in 
the Destination Folder area and browse to a results folder on your hard 
drive—you may want to make a new one with your name or initials on it 
(FIGURE 13.16). In the New Filenames area, you may need to click the Minus 
icon to the right of the list of naming conventions to simplify the file name. 
Click the Rename button.

7. Locate the results folder in the Bridge content window, then open all 10 
files (now named 01.psd, 02.psd, and so on, through 10.psd) in Photoshop. 
If your setup is similar to mine, you’ll have to click back a folder level to 
the chapter13-workfiles folder, then click into the chapter13-results folder 
to view all 10 selected files in Bridge after renaming them. Select all 10 
files, then double-click one of the selected files. This will prompt Bridge to 
open all 10 files in Photoshop. (Click OK through the warning message.)

FIGURE 13.16 Use the Batch 
Rename dialog box to cre-
ate a new file name with 
two-digit sequence num-
bers. I saved my files in the 
 chapter13-results folder 
that is shared with you on 
the companion website.  
In the rename process, 
you should point Bridge 
to a new folder with your 
name or initials on it so it is 
easy for you to locate your 
results.

If you’re working in a 
computer lab, your lab 
technician may not have 
set the preferences in 
Bridge such that the files 
open in Photoshop. You 
can use whatever tech-
nique is effective to open 
all 10 files in Photoshop.
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EXERCISE 

4 FLOAT FILES IN WINDOWS

You’ll begin this set of steps by setting up your workspace to see each docu-
ment as if it were the frame of a movie (or in your case, a flipbook).

1. With all 10 files open in tabs, choose Window > Arrange > Float All  
In Windows (FIGURE 13.17).

2. Choose Window > Arrange > Tile (FIGURE 13.18).

3. Activate one of the windows and reduce the zoom so you can see the entire 
composition in the space. (I ended up at 50%, but you may reduce to a 
lower or higher percentage depending on your screen resolution.)

4. Choose Window > Arrange > Match Zoom (FIGURE 13.19).

In theory, you could have 
simply chosen Window > 
Arrange > Tile without 
floating the images, 
but I’ve found that for 
some reason my files 
appeared out of order 
when I excluded the float 
step. Watch out for this 
in Step 5.

FIGURE 13.19 Use 
Match Zoom to see all 
the open documents 
at the same zoom 
level when they’re 
tiled in separate 
windows.

FIGURE 13.17 Float All In Windows will result 
in a stack of documents.

FIGURE 13.18 Tile the stacked documents so you can see each composition.
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5. Now all 10 documents are open. If you need to, rearrange each window so 
that you can clearly see each composition (FIGURE 13.20).

6. Look at the layout of your documents. Where is 01.psd located and where 
is 10.psd on the screen? Mine are in a logical order as long as I read from 
the top to the bottom of each column, starting on the left and ending 
on the right with the last file (10.psd). If yours are not logically ordered, 
choose File > Close All and then try this exercise again from Step 1. Alter-
natively, drag the windows to rearrange the document locations so the 
order makes sense to you.

EXERCISE 

5 NONPROGRAMMABLE MODIFICATIONS

The final steps are to modify where the balloon appears in each composition. 
This is something that you can’t program with an action, as it requires your 
eye and brain to perceive and sculpt the space.

1. Click the document 01.psd to activate it. Make sure that the balloon- 
original layer group is selected. Use the Move tool combined with Edit > 
Free Transform (Command-T/Ctrl-T) to move, scale, and rotate the balloon 
in whatever way you like. I started my flipbook with the balloon coming in 
from the left side of the document, high in the sky. You might also apply a 
layer mask to blend the balloon into the clouds (FIGURE 13.21).

FIGURE 13.20 I dragged the 
bottom edge of each docu-
ment down in order to see 
the entire composition, then 
moved the second and third 
row of documents down 
towards the bottom of my 
screen.
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2. Press Command-S/Ctrl-S to save 01.psd when you’re finished modifying the 
composition.

3. Activate 02.psd, and manipulate the balloon on the composition to suggest 
movement. Save the file when you’re done.

4. Repeat these manipulations in each of the 10 documents. You might add 
masks; reduce the opacity of the balloon; change the balloon’s rotation, 
placement, or size; or add imagery or color to the documents (FIGURE 13.22).

5. Make sure that all of your files are saved, then choose File > Close All.

FIGURE 13.21 Modify the 
first composition with Free 
Transform and a layer mask 
on the balloon-original 
layer group.

FIGURE 13.22 Modify each document separately to craft your flipbook illustration.
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EXERCISE 

6 WATCH THE SEQUENCE PLAY IN BRIDGE

Although the final result will be a printed booklet, you can preview how your 
balloon “actor” moves across the “stage” (the background layer) using the 
Filmstrip workspace in Bridge.

1. If Bridge is still open, press Command-Tab/Alt-Tab to toggle to Bridge. 
 Otherwise, open Adobe Bridge.

2. Navigate to the folder where you stored your renamed images. Activate the 
Filmstrip workspace. Click the Filmstrip button in the Application Bar or 
choose Window > Workspace > Filmstrip.

3. If the files are not displaying in the correct order in the Content area, 
choose Sort By Filename from the menu at the right end of the Application 
bar, or move the files to the left or right so they appear in sequential order.

4. Click the first file (01.psd) to select it. Press the Right Arrow key and hold it 
as Bridge displays each subsequent file in the Preview area.

LAB CHALLENGE 

Write a story that’s not physically possible in the analog world. Use digital 
manipulation tools to create a visual narrative that defies the rules of gravity, 
permanence, or time. Illustrate your story in a flipbook. Develop an action to 
create as much of the page content as can be automated, then complete the 
individual pages in Photoshop or Illustrator.
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